First login - Failed.

Solved!
Posted in General by Oleksii Thu Jul 28 2016 08:15:15 GMT+0000 (Coordinated Universal Time)·11·Viewed 1,920 times

Hi! I install owasp skf on linux and window and have one problem. I can't create admin account! I use manual https://skf.readme.io/docs/first-run on this link. I create account use 1234 and [email protected] also use any parameters. What I must do? that create user and start use skf? I will wait your answer. Thanks.
July 28, 2016

Hi Oleksii,

Yes you need to follow the steps on that page and use these values and select a password:
Pincode field: 1234
Email field: [email protected]

Username that is being configured is: admin

After that you can login with admin and your password and you can use SKF

Greetz,
Glenn

July 29, 2016

Thanks!
This information also need for other users.
I can auth in SKF.

July 13, 2017

Hello!

I was unable to activate the admin user.

The users I am using are:

User id: 1
Access token: 1234
Email: [email protected]
Username: admin
Password: *
Re-type password: *

I am doing what is written in the documentation
Https://skf.readme.io/docs/first-run

I use docker SKFAngular image: https://hub.docker.com/r/blabla1337/skf-flask/

That I'm doing wrong?

July 14, 2017

Hi Edgar,

This should work, I just tried it myself 1 minute ago. Did you do the steps below?

First get the docker image:
docker pull blabla1337/skf-flask

Then run the docker image:
docker run -e "ORIGIN=localhost" -e "JWT_SECRET=change_this_super_secret_random_string" -ti -p 127.0.0.1:443:443 blabla1337/skf-flask

The application will greet you on:
https://localhost

Also if it's still not working please join our chat channel so we can help you.
https://gitter.im/Security-Knowledge-Framework/Lobby

July 14, 2017

Hi Foobar,

Yes, I did the steps for installing SKF in Docker. SKF is running!

The problem is in the activation of user account.

I enter the data

User id: 1
Access token: 1234
Email: [email protected]
Username: admin
Password: *
Re-type password: *

Error: "Warning! User could not be activated, contact your administrator!"

You have an idea?

Thank you!

Aug 19, 2017

I have the same problem Edgar has.

The code seem to specify that we are doing the right thing, but the error persists.

In the documentation, there is this warning about the First Run: "Whenever a wrong pin number is entered the application automatically deletes the user for security purposes, should this happen the database should be set to defaults". I wonder if this is the reason why we are experiencing this issue: how could we ensure that database is set to defaults? I have removed the image and pulled it again, therefore I would expect to have reset the DB, but the error persists.

Please help!
Thank you.

Aug 19, 2017

Hi Guys,

The good news is you are getting the SKF application loaded, i think there is a small issue in how you access the application. are you using the https://127.0.0.1/ to visit the app? It will go wrong if you use localhost.

If above not helping please join the chat channel so i can help you:
https://gitter.im/Security-Knowledge-Framework/Lobby

Greetz,
Glenn


marked this as solved
Feb 8, 2019

hi guys,
i have same problem. after i do installation and go to first-run, i just follow instruction from this page https://skf.readme.io/docs/first-run . but when i click create account always show this warning

Warning! User could not be activated, contact your administrator!

is there anything wrong or incomplete tutorial ??

Feb 8, 2019

Hi Abid,

I need a bit more information, did you have it installed on a server or are you running the Docker container?
Can you maybe join our gitter channel? Its easier to troubleshoot :)
https://gitter.im/Security-Knowledge-Framework/Lobby

Kind regards,
Glenn

Feb 8, 2019

I managed to install using the docker on my computer with the Windows operating system, not finding any problems at all.
Then I tried to install it to the server using a specific ip so that my team can access it. but after being installed and entering the first-login and and follow this instruction https://skf.readme.io/docs/first-run , error message always appears.

Warning! User could not be activated, contact your administrator!

is there something wrong ? I use this command when running container :
docker run -e "ORIGIN=<my_ipaddress>" -e "JWT_SECRET=change_this_super_secret_random_string" -ti -p <my_ipaddress>:443:443 blabla1337/skf-flask

thank you :)

Apr 3, 2019

Hi, I just want to deploy the docker in a remote machine. My command is:

docker run -v /home/ubuntu/development/skf-flask/skf/db/db.sqlite:/skf-flask/skf/db/db.sqlite -e "ORIGIN=ctf.e-paths.com" -e "JWT_SECRET=ANY_SECRET" -p 443:443 blabla1337/skf-flask:stable

but when I am unable to activate the admin account.

Can anyone help me out, please?

Markdown is allowed