Unable to login on first try

Solved!
Posted in General by Matt Tue Apr 26 2016 03:00:02 GMT+0000 (UTC)·5·Viewed 178 times

I've followed the documentation with the pin code as well as trying admin:test-skf However I am unable to get past the login screen on a windows deployment. After I go through the first login prompt and enter details from the documentation pin:1234 example@owasp.org It takes me back to the login screen. however entering these details just reload the screen. If I try admin:test-skf I get an invalid login error in the logs but not for the credentials i enter after click the First Time link. Any ideas?
Matt
Apr 27, 2016

Ignore this man -he is an idiot.
Documentation didn't make it clear that its setting the admin account on first try with 1234.
I thought a user was being created with the email as the username, read the code understood what was going on.

Love opensource.

Dave
May 13, 2016

Hi Matt, how exactly did you get it to work?

I followed the installation instructions, went to https://192.168.33.118/first-login, even used the exact credentials (1234 in pin and example@owasp.org as email). I got redirected to the main loginpage. I entered 1234 as username. After pressing the Login-button I got redirected to the same loginpage, no errormessages or anything present.

Because I couldn't get flask to work (as the manual stated that user accounts would be deleted), I simply deleted the entire virtual machine and let Kitchen make a new one. This time I did exactly the same but used example@owasp.org as username rather than 1234, same result. No error messages, redirected to the same loginpage.

Matt
May 15, 2016

The only active user at the start is 'admin' so the password you have created is for that user. So use the password you created with the user admin and you should be ok.
After logging in you can create new accounts.

Foobar
May 24, 2016

Thank you for the feedback guys, we will try to update the documentation so it will be more clear what to expect when you first install/use this application. Please let me know if you have any other good feedback :)

Greetz,
Glenn


Foobar marked this as solved
Oleksii
July 28, 2016

I have this problem too now.

Markdown is allowed