Trouble installing on Windows: Point_conversion_form_t

Solved!
Posted in General by Tanya Thu Dec 03 2015 19:29:08 GMT+0000 (UTC)·12·Viewed 472 times

I'm installing skf on Windows 7 (64bit) and it won't start. I installed python which had the following errors (not sure if it's related) Running setup.py (path:/Users/bc/dev/flasktest/.venv/build/Flask/setup.py) egg_info for package Flask warning: no files found matching '*' under directory 'tests' warning: no previously-included files matching '*.pyc' found under directory 'docs' warning: no previously-included files matching '*.pyo' found under directory 'docs' warning: no previously-included files matching '*.pyc' found under directory 'tests' warning: no previously-included files matching '*.pyo' found under directory 'tests' warning: no previously-included files matching '*.pyc' found under directory 'examples' warning: no previously-included files matching '*.pyo' found under directory 'examples' no previously-included directories found matching 'docs/_build' no previously-included directories found matching 'docs/_themes/.git' But then it sais "requirement already satisfied", so I assumed it was fine. Just mentioning it in case that's the problem. So when I run python.exe skf.py it says this, and then freezes. Microsoft Windows [Version 6.1.7601] Copyright (c) 2009 Microsoft Corporation. All rights reserved. C:\Users\scanner>C:\Python27\Scripts\pip.exe install https://github.com/mitsuhik o/flask/tarball/master Downloading/unpacking https://github.com/mitsuhiko/flask/tarball/master Running setup.py (path:c:\users\scanner\appdata\local\temp\pip-ychsic-build\se tup.py) egg_info for package from https://github.com/mitsuhiko/flask/tarball/mas ter warning: no previously-included files matching '*.pyc' found under directory 'docs' warning: no previously-included files matching '*.pyo' found under directory 'docs' warning: no previously-included files matching '*.pyc' found under directory 'tests' warning: no previously-included files matching '*.pyo' found under directory 'tests' warning: no previously-included files matching '*.pyc' found under directory 'examples' warning: no previously-included files matching '*.pyo' found under directory 'examples' no previously-included directories found matching 'docs\_build' no previously-included directories found matching 'docs\_themes' Requirement already satisfied (use --upgrade to upgrade): Flask==0.11.dev0 fro m https://github.com/mitsuhiko/flask/tarball/master in c:\python27\lib\site-pack ages Requirement already satisfied (use --upgrade to upgrade): Werkzeug>=0.7 in c:\py thon27\lib\site-packages (from Flask==0.11.dev0) Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.4 in c:\pyth on27\lib\site-packages (from Flask==0.11.dev0) Requirement already satisfied (use --upgrade to upgrade): itsdangerous>=0.21 in c:\python27\lib\site-packages (from Flask==0.11.dev0) Requirement already satisfied (use --upgrade to upgrade): click>=2.0 in c:\pytho n27\lib\site-packages (from Flask==0.11.dev0) Cleaning up... C:\Users\scanner>C:\Python27\Scripts\pip.exe install owasp-skf Requirement already satisfied (use --upgrade to upgrade): owasp-skf in c:\python 27\lib\site-packages Requirement already satisfied (use --upgrade to upgrade): markdown==2.6.2 in c:\ python27\lib\site-packages (from owasp-skf) Requirement already satisfied (use --upgrade to upgrade): BeautifulSoup in c:\py thon27\lib\site-packages (from owasp-skf) Requirement already satisfied (use --upgrade to upgrade): python-docx in c:\pyth on27\lib\site-packages (from owasp-skf) Requirement already satisfied (use --upgrade to upgrade): lxml==3.4.2 in c:\pyth on27\lib\site-packages (from owasp-skf) Requirement already satisfied (use --upgrade to upgrade): cryptography==0.8.2 in c:\python27\lib\site-packages (from owasp-skf) Requirement already satisfied (use --upgrade to upgrade): pyOpenSSL in c:\python 27\lib\site-packages (from owasp-skf) Requirement already satisfied (use --upgrade to upgrade): requests in c:\python2 7\lib\site-packages (from owasp-skf) Requirement already satisfied (use --upgrade to upgrade): importlib in c:\python 27\lib\site-packages (from owasp-skf) Requirement already satisfied (use --upgrade to upgrade): flask-bcrypt in c:\pyt hon27\lib\site-packages (from owasp-skf) Requirement already satisfied (use --upgrade to upgrade): Flask in c:\python27\l ib\site-packages (from flask-bcrypt->owasp-skf) Requirement already satisfied (use --upgrade to upgrade): bcrypt in c:\python27\ lib\site-packages (from flask-bcrypt->owasp-skf) Requirement already satisfied (use --upgrade to upgrade): Werkzeug>=0.7 in c:\py thon27\lib\site-packages (from Flask->flask-bcrypt->owasp-skf) Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.4 in c:\pyth on27\lib\site-packages (from Flask->flask-bcrypt->owasp-skf) Requirement already satisfied (use --upgrade to upgrade): itsdangerous>=0.21 in c:\python27\lib\site-packages (from Flask->flask-bcrypt->owasp-skf) Requirement already satisfied (use --upgrade to upgrade): click>=2.0 in c:\pytho n27\lib\site-packages (from Flask->flask-bcrypt->owasp-skf) Cleaning up... C:\Users\scanner>cd C:\Python27\Lib\site-packages\skf C:\Python27\Lib\site-packages\skf>C:\Python27\python.exe skf.py C:\Python27\lib\site-packages\cffi\model.py:526: UserWarning: 'point_conversion_ form_t' has no values explicitly defined; next version will refuse to guess whic h integer type it is meant to be (unsigned/signed, int/long) % self._get_c_name()) Generated Password for access SKF: test-skf * Restarting with stat C:\Python27\lib\site-packages\cffi\model.py:526: UserWarning: 'point_conversion_ form_t' has no values explicitly defined; next version will refuse to guess whic h integer type it is meant to be (unsigned/signed, int/long) % self._get_c_name()) Generated Password for access SKF: test-skf * Debugger is active! * Debugger pin code: 188-942-294 Then it just hangs. What do I do?
Foobar
Dec 6, 2015

Hi Tanya,

I see you have tried to install the development branch that is not stable.
We are working on a new Major release and will be almost done, we are now in the review/pentest phase.

So let us release this in the next days and update the documentation so you can install it.
I will leave this ticket open until you are able to install it yourself correctly.

Greetz,
Glenn

Tanya
Dec 6, 2015

Oh that's good to know, thanks! I look forward to being able to use this product when it's ready for release. Thanks!

Tanya
Dec 16, 2015

Hi! When do you think the new release will be ready?

Foobar
Dec 16, 2015

Hi Tanya,

We are currently busy preparing the release and aiming for tonight ^^
Will give you a ping here when the new version is released.

Greetz,
Glenn

Foobar
Dec 16, 2015

Hi Tanya,

We have released the new version of SKF. Can you please give it a try?
Also make sure you check the 'First run' section on this site for setting up the admin account and password.

Greetz,
Glenn

Tanya
Dec 23, 2015

Hi Glenn,

I tried installing again, got similar errors, but then it says the server is running (with an error). When I go to the ip address my browser times out. I am now installing on a different VM, so it's not Windows 64-bit this time, but it is Win 7 service pack one.

Here's what I have in my cmd prompt:

C:>C:\Python27\Scripts\pip.exe install https://github.com/mitsuhiko/flask/tarba
ll/master
Downloading/unpacking https://github.com/mitsuhiko/flask/tarball/master
Running setup.py (path:c:\temp\1\pip-qsu_xd-build\setup.py) egg_info for packa
ge from https://github.com/mitsuhiko/flask/tarball/master

warning: no previously-included files matching '*.pyc' found under directory

'docs'
warning: no previously-included files matching '.pyo' found under directory
'docs'
warning: no previously-included files matching '
.pyc' found under directory
'tests'
warning: no previously-included files matching '.pyo' found under directory
'tests'
warning: no previously-included files matching '
.pyc' found under directory
'examples'
warning: no previously-included files matching '*.pyo' found under directory
'examples'
no previously-included directories found matching 'docs_build'
no previously-included directories found matching 'docs_themes'
Downloading/unpacking Werkzeug>=0.7 (from Flask==0.11.dev0)
Downloading/unpacking Jinja2>=2.4 (from Flask==0.11.dev0)
Downloading/unpacking itsdangerous>=0.21 (from Flask==0.11.dev0)
Running setup.py (path:c:\temp\1\pip_build_tjanca\itsdangerous\setup.py) egg_i
nfo for package itsdangerous

warning: no previously-included files matching '*' found under directory 'do

cs_build'
Downloading/unpacking click>=2.0 (from Flask==0.11.dev0)
Downloading/unpacking MarkupSafe (from Jinja2>=2.4->Flask==0.11.dev0)
Downloading MarkupSafe-0.23.tar.gz
Running setup.py (path:c:\temp\1\pip_build_tjanca\MarkupSafe\setup.py) egg_inf
o for package MarkupSafe

Installing collected packages: Werkzeug, Jinja2, itsdangerous, click, Flask, Mar
kupSafe
Running setup.py install for itsdangerous

warning: no previously-included files matching '*' found under directory 'do

cs_build'
Running setup.py install for Flask

warning: no previously-included files matching '*.pyc' found under directory

'docs'
warning: no previously-included files matching '.pyo' found under directory
'docs'
warning: no previously-included files matching '
.pyc' found under directory
'tests'
warning: no previously-included files matching '.pyo' found under directory
'tests'
warning: no previously-included files matching '
.pyc' found under directory
'examples'
warning: no previously-included files matching '*.pyo' found under directory
'examples'
no previously-included directories found matching 'docs_build'
no previously-included directories found matching 'docs_themes'
Installing flask-script.py script to C:\Python27\Scripts
Installing flask.exe script to C:\Python27\Scripts
Installing flask.exe.manifest script to C:\Python27\Scripts
Running setup.py install for MarkupSafe

building 'markupsafe._speedups' extension
==========================================================================
WARNING: The C extension could not be compiled, speedups are not enabled.
Failure information, if any, is above.
Retrying the build without the C extension now.


==========================================================================
WARNING: The C extension could not be compiled, speedups are not enabled.
Plain-Python installation succeeded.
==========================================================================

Successfully installed Werkzeug Jinja2 itsdangerous click Flask MarkupSafe
Cleaning up...

C:>C:\Python27\Scripts\pip.exe install owasp-skf
Downloading/unpacking owasp-skf
Running setup.py (path:c:\temp\1\pip_build_tjanca\owasp-skf\setup.py) egg_info
for package owasp-skf

package init file 'skf\__init__.py' not found (or not a regular file)

Downloading/unpacking markdown==2.6.2 (from owasp-skf)
Downloading/unpacking BeautifulSoup (from owasp-skf)
Downloading BeautifulSoup-3.2.1.tar.gz
Running setup.py (path:c:\temp\1\pip_buildtjanca\BeautifulSoup\setup.py) egg
info for package BeautifulSoup

Downloading/unpacking python-docx (from owasp-skf)
Running setup.py (path:c:\temp\1\pip_build_tjanca\python-docx\setup.py) egg_in
fo for package python-docx

Downloading/unpacking lxml==3.4.2 (from owasp-skf)
Downloading/unpacking cryptography==0.8.2 (from owasp-skf)
Downloading/unpacking pyOpenSSL (from owasp-skf)
Downloading/unpacking requests (from owasp-skf)
Downloading/unpacking importlib (from owasp-skf)
Downloading importlib-1.0.3.tar.bz2
Running setup.py (path:c:\temp\1\pip_build_tjanca\importlib\setup.py) egg_info
for package importlib

Downloading/unpacking Bcrypt==1.1.1 (from owasp-skf)
Downloading/unpacking flask-bcrypt (from owasp-skf)
Downloading Flask-Bcrypt-0.7.1.tar.gz
Running setup.py (path:c:\temp\1\pip_build_tjanca\flask-bcrypt\setup.py) egg_i
nfo for package flask-bcrypt

Downloading/unpacking pyasn1 (from cryptography==0.8.2->owasp-skf)
Downloading pyasn1-0.1.9-py2.py3-none-any.whl
Downloading/unpacking enum34 (from cryptography==0.8.2->owasp-skf)
Running setup.py (path:c:\temp\1\pip_build_tjanca\enum34\setup.py) egg_info fo
r package enum34

Downloading/unpacking cffi>=0.8 (from cryptography==0.8.2->owasp-skf)
Downloading/unpacking six>=1.4.1 (from cryptography==0.8.2->owasp-skf)
Downloading six-1.10.0-py2.py3-none-any.whl
Requirement already satisfied (use --upgrade to upgrade): setuptools in c:\pytho
n27\lib\site-packages (from cryptography==0.8.2->owasp-skf)
Requirement already satisfied (use --upgrade to upgrade): Flask in c:\python27\l
ib\site-packages (from flask-bcrypt->owasp-skf)
Downloading/unpacking pycparser (from cffi>=0.8->cryptography==0.8.2->owasp-skf)

Running setup.py (path:c:\temp\1\pip_build_tjanca\pycparser\setup.py) egg_info
for package pycparser

warning: no previously-included files matching 'yacctab.*' found under direc

tory 'tests'
warning: no previously-included files matching 'lextab.' found under direct
ory 'tests'
warning: no previously-included files matching 'yacctab.
' found under direc
tory 'examples'
warning: no previously-included files matching 'lextab.*' found under direct
ory 'examples'
Requirement already satisfied (use --upgrade to upgrade): Werkzeug>=0.7 in c:\py
thon27\lib\site-packages (from Flask->flask-bcrypt->owasp-skf)
Requirement already satisfied (use --upgrade to upgrade): Jinja2>=2.4 in c:\pyth
on27\lib\site-packages (from Flask->flask-bcrypt->owasp-skf)
Requirement already satisfied (use --upgrade to upgrade): itsdangerous>=0.21 in
c:\python27\lib\site-packages (from Flask->flask-bcrypt->owasp-skf)
Requirement already satisfied (use --upgrade to upgrade): click>=2.0 in c:\pytho
n27\lib\site-packages (from Flask->flask-bcrypt->owasp-skf)
Installing collected packages: owasp-skf, markdown, BeautifulSoup, python-docx,
lxml, cryptography, pyOpenSSL, requests, importlib, Bcrypt, flask-bcrypt, pyasn1
, enum34, cffi, six, pycparser
Running setup.py install for owasp-skf
package init file 'skf__init__.py' not found (or not a regular file)

Running setup.py install for BeautifulSoup

Running setup.py install for python-docx

Running setup.py install for importlib

Running setup.py install for flask-bcrypt

Running setup.py install for enum34

Running setup.py install for pycparser

warning: no previously-included files matching 'yacctab.*' found under direc

tory 'tests'
warning: no previously-included files matching 'lextab.' found under direct
ory 'tests'
warning: no previously-included files matching 'yacctab.
' found under direc
tory 'examples'
warning: no previously-included files matching 'lextab.*' found under direct
ory 'examples'
Build the lexing/parsing tables
Successfully installed owasp-skf markdown BeautifulSoup python-docx lxml cryptog
raphy pyOpenSSL requests importlib Bcrypt flask-bcrypt pyasn1 enum34 cffi six py
cparser
Cleaning up...

C:>cd C:\Python27\Lib\site-packages\skf

C:\Python27\Lib\site-packages\skf>C:\Python27\python.exe skf.py
C:\Python27\lib\site-packages\cffi\model.py:526: UserWarning: 'pointconversion
form_t' has no values explicitly defined; next version will refuse to guess whic
h integer type it is meant to be (unsigned/signed, int/long)
% self._get_c_name())

And this is when I go to https://127.0.0.1:5443/ in my browser, and it times out. I tried a few times, and tried stopping and restarting SKF and it still times out.

Any ideas?

Foobar
Dec 23, 2015

Hi Tanja,

Yes we created a Chef cookbook for the creation of the VM with using CentOS 7.1 as the OS.
The cookbook will create the SKF project with the correct configuration and it's all automated :D

See the new section on the Installation page and do the steps mentioned there:
https://skf.readme.io/docs/installation

Automated Chef installation

Please let me know if this works for you.

Greetz,
Glenn

Tanya
Jan 5, 2016

Hi guys,

I don't have a Linux VM available to me at work. I tried installing it at home on my mac, following your mac install instructions, and it errors out on the SKF install, saying I don't have the directories it needs.

On my Windows VM it looks like perhaps my port isn't open, is there a port that needs to be open for the app to work? If so, could you let me know and add it to the instructions?

I don't have a linux box available to me to do the install on directly. I only have VMs and a Mac.

For the Chef auto-install: do you want someone to use CentOS and then install Virtual box, the chef dev kit and vagrant on it, then run the text commands? It's not clear in your direction that CentOS is required. I work in a virtual environment for dev at work, meaning I need to use a Vm to do this work, and virtual box won't run/install on a VM.

I'm not trying to be critical, I'm trying to help. I want this to work. I really want to use this product that you can have created. I think your team needs to work on your install package and make the directions for installing more clear. Let me know if you have an update for me.

Thanks.
Tanya

Foobar
Jan 5, 2016

Hi Tanya,

We appreciate your feedback and we are glad to help you out. I updated the Chef how to so it will be more clear what is expected. This Chef method is the best approach because it will create the SKF application with the right configuration and will always work on every machine/laptop.

For your Mac at home i would advise to follow and use the Chef installation/Setup. I just modified it to give more context.

For your windows setup i really need some more information to help debugging the issue. Can you make some time to do a hangout session on Google Talk to see and discuss the problem with me?

My e-mail address is glenn.ten.cate@owasp.org

Greetz,
Glenn

Tanya
Jan 7, 2016

Glenn, I'll email you later in the week. Sorry, work has been hectic. Thanks so much for your support, I really appreciate it! Talk soon.

Tanya

Matt
Apr 22, 2016

Hi - was there any fix found for this?
I am suffering the same issues as Tanya on the Windows platform.

Foobar
Apr 28, 2016

Hi Matt,

It's depending on what windows version you are installing it. I tried the SKF application on a Windows 2012 R2 version and it worked out the box. What version of Windows are you using? Maybe i can try it here also to see what can possible go wrong.

Greets,
Glenn


Foobar marked this as solved
Markdown is allowed