Installation fails on Ubuntu 64 bit

Solved!
Posted in General by Chris Highfield Wed Nov 04 2015 14:20:47 GMT+0000 (UTC)·3·Viewed 224 times

When following the installation instructions on a 64bit Ubuntu VM (Ubuntu 14.04.3 LTS (GNU/Linux 3.13.0-66-generic x86_64) running via Vagrant the following error is generated when running "sudo pip install owasp-skf": creating build/temp.linux-x86_64-2.7/src/lxml x86_64-linux-gnu-gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -I/usr/include/libxml2 -I/tmp/pip_build_root/lxml/src/lxml/includes -I/usr/include/python2.7 -c src/lxml/lxml.etree.c -o build/temp.linux-x86_64-2.7/src/lxml/lxml.etree.o -w x86_64-linux-gnu-gcc: internal compiler error: Killed (program cc1) This does not happen in the 32 bit version of Ubuntu.
Foobar
Nov 4, 2015

Hmm i need to investigate this but looks that version we use of lxml is not stable. Thank you for the report


Foobar marked this as solved
Foobar
July 14, 2017

Please use the docker solution


Foobar marked this as solved
Markdown is allowed